「Gem関連」の版間の差分

提供: 文具堂 Wiki三昧
ナビゲーションに移動 検索に移動
9行目: 9行目:
== gemをバージョンダウンする ==
== gemをバージョンダウンする ==
[http://d.hatena.ne.jp/ruedap/20110221/ruby_gem_update_version_down RubyGemsをバージョンダウンしたりバージョンアップしたり-アインシュタインの電話番号]
[http://d.hatena.ne.jp/ruedap/20110221/ruby_gem_update_version_down RubyGemsをバージョンダウンしたりバージョンアップしたり-アインシュタインの電話番号]
<pre>
gem list rubygems-update
*** LOCAL GEMS ***
rubygems-update (1.8.6)
# gem -v
1.8.6
# gem list rubygems-update -ra     
*** REMOTE GEMS ***
rubygems-update (1.8.6, 1.8.5, 1.8.4, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.2, 1.6.1, 1.6.0, 1.5.3, 1.5.2, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.7, 1.3.6, 1.3.5, 1.3.4, 1.3.3, 1.3.2, 1.3.1, 1.3.0, 1.2.0, 1.1.1, 1.1.0, 1.0.1, 1.0.0, 0.9.5, 0.9.4, 0.9.3, 0.9.2, 0.9.1, 0.9.0, 0.8.11, 0.8.10, 0.8.8, 0.8.6, 0.8.5, 0.8.4, 0.8.3)
# gem uninstall -v 1.8.6 rubygems-update
Remove executables:
        update_rubygems
in addition to the gem? [Yn]  ERROR:  Interrupted
# gem install -v 1.6.2 rubygems-update
Fetching: rubygems-update-1.6.2.gem (100%)
Successfully installed rubygems-update-1.6.2
1 gem installed
Installing ri documentation for rubygems-update-1.6.2...
Installing RDoc documentation for rubygems-update-1.6.2...
# gem uninstall -v 1.8.6 rubygems-update
Successfully uninstalled rubygems-update-1.8.6
# update_rubygems
RubyGems 1.6.2 installed
=== 1.6.2 / 2011-03-08
Bug Fixes:
* require of an activated gem could cause activation conflicts.  Fixes
  Bug #29056 by Dave Verwer.
* `gem outdated` now works with up-to-date prerelease gems.
------------------------------------------------------------------------------
RubyGems installed the following executables:
        /usr/local/bin/gem
</pre>

2011年7月31日 (日) 20:31時点における版

インストールできるバージョンの確認

gem list -ra rails


gemをバージョンダウンする

RubyGemsをバージョンダウンしたりバージョンアップしたり-アインシュタインの電話番号

gem list rubygems-update

*** LOCAL GEMS ***

rubygems-update (1.8.6)
# gem -v
1.8.6
# gem list rubygems-update -ra      

*** REMOTE GEMS ***

rubygems-update (1.8.6, 1.8.5, 1.8.4, 1.8.3, 1.8.2, 1.8.1, 1.8.0, 1.7.2, 1.7.1, 1.7.0, 1.6.2, 1.6.1, 1.6.0, 1.5.3, 1.5.2, 1.5.0, 1.4.2, 1.4.1, 1.4.0, 1.3.7, 1.3.6, 1.3.5, 1.3.4, 1.3.3, 1.3.2, 1.3.1, 1.3.0, 1.2.0, 1.1.1, 1.1.0, 1.0.1, 1.0.0, 0.9.5, 0.9.4, 0.9.3, 0.9.2, 0.9.1, 0.9.0, 0.8.11, 0.8.10, 0.8.8, 0.8.6, 0.8.5, 0.8.4, 0.8.3)
# gem uninstall -v 1.8.6 rubygems-update
Remove executables:
        update_rubygems

in addition to the gem? [Yn]  ERROR:  Interrupted
# gem install -v 1.6.2 rubygems-update
Fetching: rubygems-update-1.6.2.gem (100%)
Successfully installed rubygems-update-1.6.2
1 gem installed
Installing ri documentation for rubygems-update-1.6.2...
Installing RDoc documentation for rubygems-update-1.6.2...
# gem uninstall -v 1.8.6 rubygems-update
Successfully uninstalled rubygems-update-1.8.6
# update_rubygems 
RubyGems 1.6.2 installed

=== 1.6.2 / 2011-03-08

Bug Fixes:

* require of an activated gem could cause activation conflicts.  Fixes
  Bug #29056 by Dave Verwer.
* `gem outdated` now works with up-to-date prerelease gems.


------------------------------------------------------------------------------

RubyGems installed the following executables:
        /usr/local/bin/gem